DPLv2 dependency update causes DPLv2 deployments to fail
Incident Report for Travis CI
Monitoring
Updates in DPLv2 and Travis CI build environments applied. We are monitoring. DPLv2 may be promoted to be default DPL function after Sep 14th.
Posted Sep 11, 2024 - 10:45 UTC
Update
TCI Enterprise server version 3.0.58 patch published and recommended to be used no later than by Sep-14th, 2024.
Posted Sep 05, 2024 - 10:24 UTC
Update
Updating build environment images still in progress - additional dependencies were identified and are worked on. Until build environment updates are finished, DPLv1 works normally, DPLv2 users are recommended to continue using uri gem update workaround.

TCI Enterprise server version will receive patch 3.0.58 shortly. Patch will ensure stability of default DPL gem used while still allowing to select different DPL version - please watch enterprise changelog.
Posted Sep 03, 2024 - 11:54 UTC
Update
We have reverted DPLv2 gem from being latest stable in gem repository, 1.10.16 is now latest stable. This doesn't affect TCI Hosted users. This should prevent TCI Enterprise server environments not updated to TCIE v3.1 suffer from necessity to update individual .travis.yml files, via appointing specific dpl gem version.

Image updates in progress and will be tested afterwards. Next update expected on September/2.
Posted Aug 30, 2024 - 13:26 UTC
Identified
We have released DPLv2 as stable gem on Aug-28th into Travis gem collection. There's an issue for DPLv2 users and there's available workaround.

The 'uri' gem updated 2 days ago caused DPLv2 2.0.5 not work correctly in Travis CI build environments due to dependency chain. This means some of your deployment recipes using 'deploy' and `dpl_version: 2.0.5` keyword can cease working.

We recommend our DPLv2 users to add temporarily following snippet to your .travis.yml as a workaround:

```
before_deploy:
- gem update uri
```

We are updating our build environments and will close this incident once that's done.
Posted Aug 29, 2024 - 14:07 UTC